Installflashpolicyd

From IRC Wiki
Jump to: navigation, search

This page demonstrates how to install a flash policy deamon that must be installed to use web chats like LightIRC

This flash policy deamon requires ruby to be installed.

Contents

Install without root

This demonstrates how to run flash without root. Login via ssh then do:

wget http://www.lightirc.com/release/flashpolicyd.zip
unzip flashpolicyd.zip
cd flashpolicyd
chmod a+x flashpolicyd.rb
./flashpolicyd.rb --xml flashpolicy.xml --logfile flashpolicyd.log --port 8002
ps x

(then check flashpolicy is in the list that appears, if so it has been installed successfully)

You will have to change the policyPort to 8002 for Lightirc to recognize the different Flashpolicy deamon port.

Install with root

If you have root access start flashpolicyd like this:

wget http://www.lightirc.com/release/flashpolicyd.zip
unzip flashpolicyd.zip
cd flashpolicyd
chmod a+x flashpolicyd.rb
./flashpolicyd.rb --xml flashpolicy.xml --logfile flashpolicyd.log
ps x

(then check flashpolicy is in the list that appears, if so it has been installed successfully)

Please note

Sometimes this flashpolicy deamon may crash, if this happens lightirc users wont be able to connect. Simply go through the above steps to restart it or set --logfile to /dev/stdout or /dev/null.

More information

Personal tools
Namespaces

Variants
Actions
Navigation
Help
Toolbox